HP FC SAN Switch admin password recovery

on July 28 | in STORAGE | by | with No Comments

During firmware upgrade activity one HP Enclouser SAN switch password was not working, so I have recovered the password by using below commands, after that SAN switch up-gradation complete.

 

  1. Reboot the switch from ilo.
  2. Press ESC at the message and Hit ESC to stop autoboot:

The system is coming up, please wait…

Read board ID of 0x8c from addr 0x23

Read extended model ID of 0x1c from addr 0x22

Matched board/model ID to platform index 10

 

Read board ID of 0x8c from addr 0x23

Read extended model ID of 0x1c from addr 0x22

Matched board/model ID to platform index 13

Checking system RAM – press any key to stop test

 

Checking memory address: 00100000

 

System RAM test using Default POST RAM Test succeeded.

 

Press escape within 4 seconds to enter boot interface.

 

1) Start system.

2) Recover password.

3) Enter command shell.

 

Option? 3   [ Type 3 and Press Enter Key ]

Password:

> printenv  [ to see environment variable ]

AutoLoad=yes

ENET_MAC=00051E9C507E

InitTest=MEM()

LoadIdentifiers=Fabric Operating System;Fabric Operating System

OSLoadOptions=quiet

OSLoader=ATA()0x146f8;ATA()0x41a10

OSRootPartition=hda1;hda2

SkipWatchdog=yes

> setenv OSLoadOptions=single  [ Type this command to login in single User Mode ]

> printenv

AutoLoad=yes

ENET_MAC=00051E9C507E

InitTest=MEM()

LoadIdentifiers=Fabric Operating System;Fabric Operating System

OSLoadOptions=single

OSLoader=ATA()0x146f8;ATA()0x41a10

OSRootPartition=hda1;hda2

SkipWatchdog=yes

> auto  [ Type auto to boot in single user mode ]

Booting “Fabric Operating System” image.

Entry point at 0x01000000 …

 

loading kernel

 

loaded at:     01000000 013F9364

board data at: 013F7324 013F7364

relocated to:  01005110 01005150

zimage at:     0100597D 0116BD5F

initrd at:     0116C000 013F6C00

avail ram:     013FA000 10000000

 

Linux/PPC load:

BootROM command line: single

Uncompressing Linux…done.

Now booting the kernel

Linux version 2.6.14.2 (swrel@blc-2-1) (gcc version 3.4.6) #1 Thu Jun 5 23:27:31                                                                                                                      PDT 2008

ppc440_setup_arch(): Not setting the 100MBFull for eth1 on this SWBD43

Silkworm CPLD [board: 43, rev: 1]

Brocade Silkworm port (C) 2002 MontaVista Software, Inc. (source@mvista.com)

Built 1 zonelists

Kernel command line: single

PID hash table entries: 2048 (order: 11, 32768 bytes)

Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)

Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)

Memory: 253824k available (2348k kernel code, 640k data, 108k init, 0k highmem)

Mount-cache hash table entries: 512

checking if image is initramfs…it isn’t (bad gzip magic numbers); looks like a                                                                                                                     n initrd

Freeing initrd memory: 2603k freed

NET: Registered protocol family 16

PCI: Probing PCI hardware

PCI: Cannot allocate resource region 0 of device 0000:00:00.0

SGI XFS with no debug enabled

IBM gpio driver version 06.12.06

SWBD Platform Driver v1.0: [type 43, rev 1].

Config Silkworm

PPC 405 watchdog driver v0.51. (Timer driven)

Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled

ttyS0 at MMIO 0x0 (irq = 1) is a 16550A

ttyS1 at MMIO 0x0 (irq = 0) is a 16550A

io scheduler noop registered

RAMDISK driver initialized: 1 RAM disks of 50000K size 1024 blocksize

loop: loaded (max 8 devices)

PPC 4xx OCP EMAC driver, version 3.54

mal0: initialized, 4 TX channels, 2 RX channels

zmii0: bridge in RMII mode

eth0: emac0, MAC 00:05:1e:9c:50:7e

eth0: found Generic MII PHY (0x01)

emac1: can’t find PHY!

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

read cpld_data 0xc2

Silkworm CE-2 CPLD ATA interface configured [CPLD version 2]

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

cpld_ide_init_hwif_ports: dp=0, cp=0, hw=c1123f50

hda: STI Flash 8.0.0, CFA DISK drive

ide0 at 0xd301b1f0-0xd301b1f7,0xd301b3f6 on irq 28

hda: max request size: 128KiB

hda: 501760 sectors (256 MB), CHS=980/16/32

hda: cache flushes not supported

hda: hda1 hda2

ATA polled-mode panic dumper on char-major-252.

mtdchar: write-caching enabled

silkworm: Using SWBD34 flash configuration

Boot flash: Found 1 x16 devices at 0x0 in 16-bit bank

Intel/Sharp Extended Query Table at 0x0031

Using buffer write method

cfi_cmdset_0001: Erase suspend on write enabled

Creating 6 MTD partitions on “Boot flash”:

0x00000000-0x00020000 : “bootenv0: boot environment (1)”

0x00020000-0x00040000 : “bootenv1: boot environment (2)”

0x00040000-0x00200000 : “prom0: boot prom (1)”

0x00200000-0x003c0000 : “prom1: boot prom (2)”

0x003c0000-0x003e0000 : “unused”

0x003e0000-0x00400000 : “bootsel: boot prom selector”

i2c /dev entries driver

IBM IIC driver v2.1

ibm-iic0: using standard (100 kHz) mode

ibm-iic1: using standard (100 kHz) mode

M41T11 Real-time-clock Driver v1.1

m41t11: Called to probe for bus IIC-0

m41t11: I2C Real-Time-Clock detected on iic0 addr 0x68

NET: Registered protocol family 2

IP route cache hash table entries: 4096 (order: 2, 16384 bytes)

TCP established hash table entries: 16384 (order: 4, 65536 bytes)

TCP bind hash table entries: 16384 (order: 4, 65536 bytes)

TCP: Hash tables configured (established 16384 bind 16384)

TCP reno registered

ip_tables: (C) 2000-2002 Netfilter core team

TCP bic registered

NET: Registered protocol family 1

NET: Registered protocol family 10

IPv6 over IPv4 tunneling driver

ip6_tables: (C) 2000-2002 Netfilter core team

NET: Registered protocol family 17

RAMDISK: ext2 filesystem found at block 0

RAMDISK: Loading 2600KiB [1 disk] into ram disk… done.

EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended

VFS: Mounted root (ext2 filesystem).

Installing Linuxxfsshutdownhandler_module: module license ‘unspecified’ taints k                                                                                                                     ernel.

2.6 Kernel

Attempting to find a root file s hda:ystem on hda1… hda1

hda2

kjournald starting.  Commit interval 5 seconds

EXT3 FS on hda1, internal journal

EXT3-fs: recovery complete.

EXT3-fs: mounted filesystem with ordered data mode.

hda: hda1 hda2

kjournald starting.  Commit interval 5 seconds

EXT3-fs: mounted filesystem with ordered data mode.

VFS: Mounted root (ext3 filesystem) readonly.

Trying to move old root to /initrd … okay

Freeing unused kernel memory: 108k init

INIT: version 2.78 booting

 

sh-2.04# mount -o remount,rw,noatime /

EXT3 FS on hda1, internal journal

 

sh-2.04# mount /dev/hda2 /mnt

kjournald starting.  Commit interval 5 seconds

EXT3 FS on hda2, internal journal

EXT3-fs: recovery complete.

EXT3-fs: mounted filesystem with ordered data mode.

 

sh-2.04# mount

/dev/root on / type unknown (rw,noatime)

none on /proc type proc (rw)

none on /dev/pts type devpts (rw,mode=620)

none on /tmp type ramfs (rw)

/dev/hda2 on /mnt type ext3 (rw,noatime)

/dev/hda2 on /mnt type ext3 (rw)

 

sh-2.04# /sbin/passwddefault

passwdCfg: fabosInit failed with 2

All account passwords have been successfully set to factory default.

 

sh-2.04# reboot -f

Restarting system.

1351 Total Views 1 Views Today
Pin It

related posts

Comments are closed.

»